top of page

[Flutter/dart]The getter 'body1' isn't defined for the class 'TextTheme'


Phenomenon


I got a title error after updating flutter to 2.5.1.

According to the error log, the cause seems to be charts-flutter.



Cause and Solution


With the version upgrade of flutter, some duplicated ones became an error.

It seems that charts-flutter doesn't support it.

When I looked at the github page, the following was described as a provisional response.


charts_flutter: ^0.11.0

to

charts_flutter:
  git:
    url: https://github.com/google/charts.git
    path: charts_flutter

With this I can build without error.



Lastly


It seems that charts-flutter hasn't been maintained and updated recently, so I have to think about adopting it in new apps ...

Recent Posts

See All

[Flutter/Dart] Format string with TextField

What want to do I want to create an input form using TextField. For example, if the input content is a monetary amount, I would like to display it in 3-digit delimiters with a ¥ prefix. Rather than ha

Comments


Let's do our best with our partner:​ ChatReminder

iphone6.5p2.png

It is an application that achieves goals in a chat format with partners.

google-play-badge.png
Download_on_the_App_Store_Badge_JP_RGB_blk_100317.png

Let's do our best with our partner:​ ChatReminder

納品:iPhone6.5①.png

It is an application that achieves goals in a chat format with partners.

google-play-badge.png
Download_on_the_App_Store_Badge_JP_RGB_blk_100317.png

Theme diary: Decide the theme and record for each genre

It is a diary application that allows you to post and record with themes and sub-themes for each genre.

google-play-badge.png
Download_on_the_App_Store_Badge_JP_RGB_blk_100317.png
bottom of page